The new GUIs v1.15.8 will inform you about mismatching firmwares to avoid inconsistencies between the two.

When the firmware is older than the GUI, this warning will appear. Please update your firmware first in this case: http://kiss.flyduino.net/downloads/

 

If you have a newer firmware than the GUI, the message will change accordingly:
“Your firmware is NEWER than the GUI…”

In this case please use an older GUI, e.g. one of the standalone versions 1.14 from the download section: http://kiss.flyduino.net/downloads/